1SUMMARY = "A filesystem snapshot utility based on rsync"
2HOMEPAGE = "http://www.rsnapshot.org"
3BUGTRACKER = "https://sourceforge.net/projects/rsnapshot/"
4SECTION = "console/network"
5
6LICENSE = "GPL-2.0-only"
7LIC_FILES_CHKSUM = "file://COPYING;md5=892f569a555ba9c07a568a7c0c4fa63a"
8
9RDEPENDS:${PN} = "rsync \
10                  perl \
11                  perl-module-dirhandle \
12                  perl-module-cwd \
13                  perl-module-getopt-std \
14                  perl-module-file-path \
15                  perl-module-file-stat \
16                  perl-module-file-spec \
17                  perl-module-posix \
18                  perl-module-fcntl \
19                  perl-module-io-file \
20                  perl-module-constant \
21                  perl-module-overloading \
22                  perl-module-ipc-open3 \
23                 "
24
25SRCREV = "1b943dbc7695d62fac5c0f9549ec696a538be19c"
26PV = "1.4.5"
27
28SRC_URI = "git://github.com/DrHyde/${BPN};branch=master;protocol=https \
29           file://configure-fix-cmd_rsync.patch \
30          "
31
32S = "${WORKDIR}/git"
33
34inherit autotools perlnative
35
36# Fix rsnapshot.conf.default:
37# don't inject the host path into target configs.
38EXTRA_OECONF += "--without-cp \
39                 --without-rm \
40                 --without-du \
41                 --without-ssh \
42                 --without-logger \
43                 --without-rsync \
44                 ac_cv_path_PERL=${bindir}/perl \
45                 ac_cv_path_MOUNT=${base_bindir}/mount \
46                 ac_cv_path_UMOUNT=${base_bindir}/umount \
47                "
48
49# Create 't/include.ac' before starting the autoreconf to fix configure
50# error: configure.ac:302: file 't/include.ac' does not exist
51do_configure:prepend(){
52	saved_dir=`pwd`
53	cd ${S}; ./autogen.sh
54	cd ${saved_dir}
55}
56