1SUMMARY = "Reboot the device to a specific mode."
2
3LICENSE = "GPL-3.0-or-later"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=84dcc94da3adb52b53ae4fa38fe49e5d"
5
6SRC_URI = "git://gitlab.com/postmarketOS/reboot-mode.git;protocol=http;branch=master"
7SRCREV = "84831b20512abd9033414ca5f5a023f333525335"
8
9S = "${WORKDIR}/git"
10
11# Upstream repo has not made releases/tags after 1.0.0
12UPSTREAM_CHECK_COMMITS = "1"
13
14do_compile() {
15    ${CC} ${CFLAGS} ${LDFLAGS} ${S}/reboot-mode.c -o ${B}/reboot-mode
16}
17
18do_install() {
19    install -D -m 0755 ${B}/reboot-mode ${D}${bindir}/reboot-mode
20}
21