1LICENSE = "GPL-3.0-or-later"
2LIC_FILES_CHKSUM = "file://COPYING;md5=87212b5f1ae096371049a12f80034f32"
3
4SRC_URI = "https://github.com/rrthomas/psutils/releases/download/v${PV}/psutils-${PV}.tar.gz"
5SRC_URI[sha256sum] = "6f8339fd5322df5c782bfb355d9f89e513353220fca0700a5a28775404d7e98b"
6
7inherit perlnative autotools
8
9export PERL="/usr/bin/env perl"
10
11DEPENDS += "libpaper-native"
12
13do_install:append() {
14    sed -i -e 's|${STAGING_BINDIR_NATIVE}/perl-native/|/usr/bin/env |g' ${D}${bindir}/pstops
15    for f in psbook psresize psnup psselect; do
16        grep -v '${B}' ${D}${bindir}/$f > ${D}${bindir}/$f.temp
17        install -m 0755 ${D}${bindir}/$f.temp ${D}${bindir}/$f
18        rm -f ${D}${bindir}/$f.temp
19    done
20}
21
22BBCLASSEXTEND += "native"
23# /usr/bin/pstops contained in package psutils requires perl
24RDEPENDS:${PN} += "perl"
25