1SUMMARY = "Protocol plugin for Office 365/Lync/OCS for Adium, Pidgin, Miranda and Telepathy IM Framework"
2SECTION = "webos/services"
3LICENSE = "GPL-2.0-only"
4LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
5
6DEPENDS = "pidgin gmime intltool-native glib-2.0-native"
7
8inherit autotools gettext pkgconfig
9
10SRC_URI = "${SOURCEFORGE_MIRROR}/sipe/pidgin-sipe-${PV}.tar.xz \
11           file://0001-sipe-consider-64bit-time_t-when-printing.patch \
12           file://0001-Align-structs-casts-with-time_t-elements-to-8byte-bo.patch \
13           file://0001-configure-Do-not-add-native-paths-to-pkgconfig-searc.patch \
14           file://0001-Migrate-to-use-g_memdup2.patch \
15"
16
17SRC_URI[md5sum] = "0e742f021dc8c3f17435aea05c3e0314"
18SRC_URI[sha256sum] = "738b121b11f2b3f1744150c00cb381222eb6cf67161a7742797eb4f03e64a2ba"
19
20PACKAGECONFIG ??= "nss krb5"
21PACKAGECONFIG[nss] = "--enable-nss=yes,--enable-nss=no,nss"
22PACKAGECONFIG[openssl] = "--enable-openssl=yes,--enable-openssl=no,openssl"
23PACKAGECONFIG[krb5] = "--with-krb5=yes,--with-krb5=no,krb5"
24#PACKAGECONFIG[voice_and_video] = "--with-vv=yes,--with-vv=no,libnice gstreamer"
25PACKAGECONFIG[telepathy] = "--enable-telepathy=yes,--enable-telepathy=no,telepathy-glib"
26#PACKAGECONFIG[gssapi_only] = "--enable-gssapi-only=yes,--enable-gssapi-only=no,krb5"
27PACKAGECONFIG[debug] = "--enable-debug=yes,--enable-debug=no,valgrind"
28
29FILES:${PN}-dev += " \
30    ${libdir}/purple-2/*.la \
31"
32
33FILES:${PN} += " \
34    ${libdir}/purple-2/libsipe.so \
35    ${datadir}/appdata \
36    ${datadir}/metainfo \
37"
38