1DESCRIPTION = "A small network printer daemon for embedded situations that passes the job directly to the printer"
2HOMEPAGE = "http://p910nd.sourceforge.net/"
3SECTION = "console/utils"
4LICENSE = "GPL-2.0-only"
5LIC_FILES_CHKSUM = "file://LICENSE.md;md5=3d82780e8917b360cbee7b9ec3e40734"
6
7
8# v0.97
9SRCREV = "57ebc07ad8723ea4106090536c58c7f7160743e2"
10SRC_URI = "git://github.com/kenyapcomau/p910nd;protocol=https;branch=master \
11           file://fix-var-lock.patch"
12
13S = "${WORKDIR}/git"
14
15inherit update-rc.d
16
17INITSCRIPT_NAME = "p910nd"
18INITSCRIPT_PARAMS = "start 90 2 3 4 5 . stop 60 0 1 6 ."
19
20do_compile () {
21    ${CC} ${CFLAGS} ${LDFLAGS} -o p910nd p910nd.c
22}
23
24do_install () {
25    install -D -m 0755 ${S}/p910nd ${D}${sbindir}/p910nd
26    install -D -m 0644 ${S}/aux/p910nd.conf ${D}${sysconfdir}/sysconfig/p910nd.conf
27    install -D -m 0644 ${S}/aux/p910nd.init ${D}${sysconfdir}/init.d/p910nd
28}
29