1DESCRIPTION = "A small network printer daemon for embedded situations that passes the job directly to the printer"
2HOMEPAGE = "http://p910nd.sourceforge.net/"
3SECTION = "console/utils"
4LICENSE = "GPL-2.0-only"
5LIC_FILES_CHKSUM = "file://LICENSE.md;md5=3d82780e8917b360cbee7b9ec3e40734"
6
7PR = "r2"
8
9# v0.97
10SRCREV = "57ebc07ad8723ea4106090536c58c7f7160743e2"
11SRC_URI = "git://github.com/kenyapcomau/p910nd;protocol=https;branch=master \
12           file://fix-var-lock.patch"
13
14S = "${WORKDIR}/git"
15
16inherit update-rc.d
17
18INITSCRIPT_NAME = "p910nd"
19INITSCRIPT_PARAMS = "start 90 2 3 4 5 . stop 60 0 1 6 ."
20
21do_compile () {
22    ${CC} ${CFLAGS} ${LDFLAGS} -o p910nd p910nd.c
23}
24
25do_install () {
26    install -D -m 0755 ${S}/p910nd ${D}${sbindir}/p910nd
27    install -D -m 0644 ${S}/aux/p910nd.conf ${D}${sysconfdir}/sysconfig/p910nd.conf
28    install -D -m 0644 ${S}/aux/p910nd.init ${D}${sysconfdir}/init.d/p910nd
29}
30