1#
2# Copyright (C) 2012 Wind River Systems, Inc.
3#
4SUMMARY = "MCE test suite"
5
6DESCRIPTION = "The MCE test suite is a collection of tools and test scripts for \
7testing the Linux RAS related features, including CPU/Memory error \
8containment and recovery, ACPI/APEI support etc."
9
10LICENSE = "GPL-2.0-only"
11LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
12
13SRC_URI = "git://git.kernel.org/pub/scm/utils/cpu/mce/mce-test.git;protocol=git;branch=master \
14           file://makefile-remove-ldflags.patch \
15           file://0001-gcov_merge.py-scov_merge.py-switch-to-python3.patch \
16          "
17SRCREV = "025014dedca39d2b8a57a82e52286e72e157d73a"
18PV = "20222810+git"
19
20RDEPENDS:${PN} = "mcelog mce-inject dialog bash"
21
22COMPATIBLE_HOST = '(i.86|x86_64).*-linux'
23
24S ="${WORKDIR}/git"
25
26EXTRA_OEMAKE += "CFLAGS='${CFLAGS}'"
27
28do_install:append(){
29   install -d ${D}/opt/mce-test
30   cp -rf ${S}/* ${D}/opt/mce-test/
31}
32
33FILES:${PN} += "/opt"
34