1SUMMARY = "Linux machine check injector tool"
2DESCRIPTION = "mce-inject allows to inject machine check errors on the \
3software level into a running Linux kernel. This is intended for \
4validation of the kernel machine check handler."
5SECTION = "System Environment/Base"
6
7SRC_URI = "git://git.kernel.org/pub/scm/utils/cpu/mce/mce-inject.git;branch=master"
8
9SRCREV = "4cbe46321b4a81365ff3aafafe63967264dbfec5"
10
11UPSTREAM_CHECK_COMMITS = "1"
12
13DEPENDS = "bison-native"
14
15LICENSE = "GPL-2.0-only"
16LIC_FILES_CHKSUM = "file://README;beginline=30;md5=94c18755082a2da9c9cf97cba3ad47d6"
17
18S = "${WORKDIR}/git"
19
20COMPATIBLE_HOST = '(x86_64.*|i.86.*)-linux'
21
22inherit autotools-brokensep
23
24EXTRA_OEMAKE = "destdir=${D} CFLAGS='${CFLAGS}'"
25