1SUMMARY = "A privileged helper for utmp/wtmp updates"
2DESCRIPTION = "\
3This library provides interface for terminal emulators such as \
4screen and xterm to record user sessions to utmp and wtmp files."
5HOMEPAGE = "ftp://ftp.altlinux.org/pub/people/ldv/utempter"
6SECTION = "System Environment/Libraries"
7LICENSE = "GPL-2.0-only & GPL-2.0-or-later & LGPL-2.0-only & MIT"
8LIC_FILES_CHKSUM = "file://COPYING;md5=2caced0b25dfefd4c601d92bd15116de"
9
10SRCREV = "63825e2244629d44dae21132b1065d7ecc0491c0"
11
12SRC_URI = "git://git.altlinux.org/people/ldv/packages/libutempter.git;branch=master \
13           file://0001-Fix-macro-error.patch \
14           file://0002-Proper-macro-path-generation.patch \
15           "
16
17S = "${WORKDIR}/git/${BPN}"
18
19CFLAGS += "-DLIBEXECDIR=${libexecdir}"
20
21do_compile() {
22    oe_runmake                      \
23        libdir=${libdir}            \
24        libexecdir=${libexecdir}
25}
26
27do_install() {
28    oe_runmake install              \
29        DESTDIR=${D}                \
30        libdir="${libdir}"          \
31        libexecdir="${libexecdir}"  \
32        includedir=${includedir}    \
33        mandir=${mandir}
34
35    rm -f ${D}${libdir}/*.a
36}
37
38FILES:${PN} = "${libdir}/*.so.*"
39FILES:${PN} += "${libexecdir}/utempter/utempter"
40FILES:${PN}-dbg += "${libexecdir}/utempter/.debug/utempter"
41