1SUMMARY = "Fast Artificial Neural Network (FANN) Library"
2DESCRIPTION = "Fast Artificial Neural Network (FANN) Library is a free open source neural network library, which implements multilayer artificial neural networks in C with support for both fully connected and sparsely connected networks."
3HOMEPAGE = "https://github.com/libfann/fann"
4SECTION = "libs/devel"
5
6LICENSE = "LGPLv2.1"
7LIC_FILES_CHKSUM = "file://LICENSE.md;md5=f14599a2f089f6ff8c97e2baa4e3d575"
8
9inherit cmake
10
11SRCREV ?= "7ec1fc7e5bd734f1d3c89b095e630e83c86b9be1"
12SRC_URI = "git://github.com/libfann/fann.git;branch=master \
13          "
14
15PV = "2.2.0+git${SRCPV}"
16
17S = "${WORKDIR}/git"
18
19EXTRA_OECMAKE = "-DLIB_SUFFIX=${@d.getVar('baselib').replace('lib', '')}"
20