1DESCRIPTION = "The goal of this project is to provide a tiny library that would \
2facilitate the common operations with sizes in bytes."
3HOMEPAGE = "https://github.com/rhinstaller/libbytesize"
4LICENSE = "LGPL-2.0-or-later"
5SECTION = "devel/lib"
6
7LIC_FILES_CHKSUM = "file://LICENSE;md5=c07cb499d259452f324bb90c3067d85c"
8
9S = "${WORKDIR}/git"
10
11SRCREV = "6e83cc6f6dff4f126fc79284e0c3c1c50123380d"
12SRC_URI = "git://github.com/storaged-project/libbytesize;branch=main;protocol=https"
13
14inherit gettext autotools pkgconfig python3native
15
16DEPENDS += " \
17    libpcre2 \
18    gmp \
19    mpfr \
20    gettext-native \
21"
22
23FILES:${PN} += "${PYTHON_SITEPACKAGES_DIR}/bytesize"
24
25PACKAGECONFIG ??= "python3"
26PACKAGECONFIG[python3] = "--with-python3, --without-python3,,python3-core"
27
28EXTRA_OECONF = "--without-gtk-doc"
29EXTRA_OEMAKE = "py3libdir=${PYTHON_SITEPACKAGES_DIR}"
30