1SUMMARY = "Base64 Encoding/Decoding Routines"
2DESCRIPTION = "base64 encoding/decoding library - runtime library \
3libb64 is a library of ANSI C routines for fast encoding/decoding data into \
4and from a base64-encoded format"
5HOMEPAGE = "https://github.com/libb64"
6LICENSE = "PD"
7LIC_FILES_CHKSUM = "file://LICENSE.md;md5=81296a564fa0621472714aae7c763d96"
8
9PV .= "+2.0.0.2+git${SRCPV}"
10SRCREV = "ce864b17ea0e24a91e77c7dd3eb2d1ac4175b3f0"
11
12SRC_URI = "git://github.com/libb64/libb64;protocol=https;branch=master \
13           file://0001-example-Do-not-run-the-tests.patch \
14           file://0001-Makefile-fix-parallel-build-of-examples.patch \
15           file://0001-examples-Use-proper-function-prototype-for-main.patch \
16           "
17
18S = "${WORKDIR}/git"
19
20CFLAGS += "-fPIC"
21
22do_configure () {
23    :
24}
25
26do_compile () {
27    oe_runmake
28    ${CC} ${LDFLAGS} ${CFLAGS} -shared -Wl,-soname,${BPN}.so.0 src/*.o -o src/${BPN}.so.0
29}
30
31do_install () {
32    install -d ${D}${includedir}/b64
33    install -Dm 0644 ${B}/src/libb64.a ${D}${libdir}/libb64.a
34    install -Dm 0644 ${B}/src/libb64.so.0 ${D}${libdir}/libb64.so.0
35    ln -s libb64.so.0 ${D}${libdir}/libb64.so
36    install -Dm 0644 ${S}/include/b64/*.h ${D}${includedir}/b64/
37}
38