1SUMMARY = "A graphical front-end for gcov"
2HOMEPAGE = "https://github.com/linux-test-project/lcov"
3DESCRIPTION = "LCOV is a graphical front-end for GCC's coverage testing \
4tool gcov. It collects gcov data for multiple source files and creates \
5HTML pages containing the source code annotated with coverage information. \
6It also adds overview pages for easy navigation within the file structure. \
7LCOV supports statement, function and branch coverage measurement."
8LICENSE = "GPL-2.0-only"
9LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
10
11RDEPENDS:${PN} += " \
12    perl \
13    perl-module-filehandle \
14    perl-module-getopt-std \
15    perl-module-digest-md5 \
16    perl-module-digest-sha \
17    perl-module-constant \
18    perl-module-cwd \
19    perl-module-errno \
20    perl-module-file-basename \
21    perl-module-file-copy \
22    perl-module-file-find \
23    perl-module-file-path \
24    perl-module-file-spec \
25    perl-module-file-spec-functions \
26    perl-module-file-spec-unix \
27    perl-module-file-temp \
28    perl-module-getopt-long \
29    perl-module-list-util \
30    perl-module-mro \
31    perl-module-overload \
32    perl-module-overloading \
33    perl-module-overload-numbers \
34    perl-module-parent \
35    perl-module-pod-usage \
36    perl-module-posix \
37    perl-module-re \
38    perl-module-safe \
39    perl-module-scalar-util \
40    perl-module-term-cap \
41    perl-module-text-parsewords \
42    perl-module-tie-hash \
43"
44
45RDEPENDS:${PN}:append:class-target = " \
46    gcov \
47    gcov-symlinks \
48"
49SRC_URI = "https://github.com/linux-test-project/lcov/releases/download/v${PV}/lcov-${PV}.tar.gz"
50SRC_URI[md5sum] = "bfee0cef50d7b7bd1df03bfadf68dcef"
51SRC_URI[sha256sum] = "987031ad5528c8a746d4b52b380bc1bffe412de1f2b9c2ba5224995668e3240b"
52
53do_install() {
54    oe_runmake install PREFIX=${D}${prefix} CFG_DIR=${D}${sysconfdir} LCOV_PERL_PATH="/usr/bin/env perl"
55}
56
57BBCLASSEXTEND = "native nativesdk"
58