1SUMMARY = "Command line tools and C library providing a simple interface to inotify"
2HOMEPAGE = "http://wiki.github.com/rvoicilas/inotify-tools"
3SECTION = "console/devel"
4LICENSE = "GPL-2.0-only"
5LIC_FILES_CHKSUM = "file://COPYING;md5=ac6c26e52aea428ee7f56dc2c56424c6"
6
7SRCREV = "c8bdbc0a2ed822fc7c67c5c3e102d89fe27fb2d0"
8
9SRC_URI = "git://github.com/${BPN}/${BPN};branch=master;protocol=https \
10           file://0002-libinotifytools-Bridge-differences-between-musl-glib.patch \
11           file://0002-configure-Add-AC_SYS_LARGEFILE-autoconf-macro.patch \
12           file://0003-replace-stat64-lstat64-with-stat-lstat.patch \
13           "
14
15S = "${WORKDIR}/git"
16
17inherit autotools
18
19EXTRA_OECONF = "--disable-doxygen"
20
21# workaround until glibc 2.35 is fixed for this [1]
22# [1] https://sourceware.org/pipermail/libc-alpha/2021-December/134215.html
23CFLAGS += "-Wno-error"
24
25PACKAGES =+ "libinotifytools"
26
27FILES:libinotifytools = "${libdir}/lib*.so.*"
28