1SUMMARY = "The iniParser library is a simple C library offering INI file parsing services (both reading and writing)."
2SECTION = "libs"
3HOMEPAGE = "https://github.com/ndevilla/iniparser"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=e02baf71c76e0650e667d7da133379ac"
6
7DEPENDS = "doxygen-native"
8
9PV .= "+git${SRCPV}"
10
11SRC_URI = "git://github.com/ndevilla/iniparser.git;protocol=https;branch=master \
12           file://0001-iniparser.pc-Make-libpath-a-variable.patch \
13	   file://Add-CMake-support.patch"
14
15SRCREV= "deb85ad4936d4ca32cc2260ce43323d47936410d"
16
17S = "${WORKDIR}/git"
18
19inherit cmake
20
21do_install:append() {
22    install -Dm 0644 ${S}/iniparser.pc ${D}${libdir}/pkgconfig/iniparser.pc
23    sed -i -e 's,@baselib@,${baselib},g' ${D}${libdir}/pkgconfig/iniparser.pc
24}
25