1SUMMARY = "Administration program for the grsecurity RBAC syste"
2DESCRIPTION = "\
3gradm is the userspace RBAC parsing and authentication program for \
4grsecurity grsecurity aims to be a complete security system. gradm \
5performs several tasks for the RBAC system including authenticated \
6via a password to the kernel and parsing rules to be passed to the \
7kernel"
8HOMEPAGE = "http://grsecurity.net/index.php"
9SECTION = "admin"
10LICENSE = "GPL-2.0-only"
11LIC_FILES_CHKSUM = "file://LICENSE;md5=4641e94ec96f98fabc56ff9cc48be14b"
12DEPENDS = "flex-native bison-native ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
13
14SRC_URI = "http://grsecurity.net/stable/${BP}.tar.gz \
15           file://0001-Makefile-remove-strip.patch \
16           file://0001-Makefile-Append-instead-of-overriding-LDFLAGS.patch \
17           file://0001-make-Define-SBINDIR-flag.patch \
18           "
19SRC_URI[sha256sum] = "2459290f367a47c8a1ce4ea2ec08359799ea33dc15ed4436439596ce88284fb9"
20
21UPSTREAM_CHECK_URI = "https://grsecurity.net/download"
22
23S = "${WORKDIR}/gradm"
24
25inherit autotools-brokensep
26
27do_compile() {
28    oe_runmake 'CC=${CC}'                               \
29               'LIBS='                                  \
30               'OPT_FLAGS=${CFLAGS}'                    \
31               'LLEX=${STAGING_BINDIR_NATIVE}/lex'      \
32               'FLEX=${STAGING_BINDIR_NATIVE}/flex'     \
33               'BISON=${STAGING_BINDIR_NATIVE}/bison'   \
34               ${@bb.utils.contains('DISTRO_FEATURES', 'pam', ' ', 'nopam', d)}
35}
36
37do_install() {
38    oe_runmake 'CC=${CC}'                               \
39               'DESTDIR=${D}'                           \
40               'SBINDIR=${base_sbindir}'                \
41               'LIBS='                                  \
42               'LLEX=${STAGING_BINDIR_NATIVE}/lex'      \
43               'FLEX=${STAGING_BINDIR_NATIVE}/flex'     \
44               'BISON=${STAGING_BINDIR_NATIVE}/bison'   \
45               install
46
47    # The device nodes are generated by postinstall or udev
48    rm -rf ${D}/dev
49}
50
51pkg_postinst_ontarget:${PN}() {
52    /bin/mknod -m 0622 /dev/grsec c 1 13
53}
54