1SUMMARY = "Administration program for the grsecurity RBAC syste"
2DESCRIPTION = "\
3gradm is the userspace RBAC parsing and authentication program for \
4grsecurity grsecurity aims to be a complete security system. gradm \
5performs several tasks for the RBAC system including authenticated \
6via a password to the kernel and parsing rules to be passed to the \
7kernel"
8HOMEPAGE = "http://grsecurity.net/index.php"
9SECTION = "admin"
10LICENSE = "GPL-2.0-only"
11LIC_FILES_CHKSUM = "file://LICENSE;md5=4641e94ec96f98fabc56ff9cc48be14b"
12DEPENDS = "flex-native bison-native ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
13
14SRC_URI = "http://grsecurity.net/stable/${BP}.tar.gz \
15           file://0001-Makefile-remove-strip.patch \
16           file://0001-Makefile-Append-instead-of-overriding-LDFLAGS.patch \
17           file://0001-make-Define-SBINDIR-flag.patch \
18           "
19SRC_URI[sha256sum] = "2459290f367a47c8a1ce4ea2ec08359799ea33dc15ed4436439596ce88284fb9"
20
21S = "${WORKDIR}/gradm"
22
23inherit autotools-brokensep
24
25do_compile() {
26    oe_runmake 'CC=${CC}'                               \
27               'LIBS='                                  \
28               'OPT_FLAGS=${CFLAGS}'                    \
29               'LLEX=${STAGING_BINDIR_NATIVE}/lex'      \
30               'FLEX=${STAGING_BINDIR_NATIVE}/flex'     \
31               'BISON=${STAGING_BINDIR_NATIVE}/bison'   \
32               ${@bb.utils.contains('DISTRO_FEATURES', 'pam', ' ', 'nopam', d)}
33}
34
35do_install() {
36    oe_runmake 'CC=${CC}'                               \
37               'DESTDIR=${D}'                           \
38               'SBINDIR=${base_sbindir}'                \
39               'LIBS='                                  \
40               'LLEX=${STAGING_BINDIR_NATIVE}/lex'      \
41               'FLEX=${STAGING_BINDIR_NATIVE}/flex'     \
42               'BISON=${STAGING_BINDIR_NATIVE}/bison'   \
43               install
44
45    # The device nodes are generated by postinstall or udev
46    rm -rf ${D}/dev
47}
48
49pkg_postinst_ontarget:${PN}() {
50    /bin/mknod -m 0622 /dev/grsec c 1 13
51}
52