1DESCRIPTION = "A microbenchmark support library"
2HOMEPAGE = "https://github.com/google/benchmark"
3SECTION = "libs"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
6
7SRC_URI = "git://github.com/google/benchmark.git;protocol=https;branch=main \
8           file://0001-cycleclock-Fix-type-conversion-to-match-function-ret.patch \
9           file://0002-cycleclock-Fix-type-conversion-to-match-function-ret.patch"
10SRCREV = "a4cf155615c63e019ae549e31703bf367df5b471"
11
12S = "${WORKDIR}/git"
13
14EXTRA_OECMAKE = " \
15    -DBUILD_SHARED_LIBS=yes \
16    -DBENCHMARK_ENABLE_TESTING=no \
17    -DCMAKE_BUILD_TYPE=Release \
18"
19
20inherit cmake
21
22FILES:${PN}-dev += "${libdir}/cmake"
23