1SUMMARY = "The GNU portability library"
2DESCRIPTION = "A collection of software subroutines which are designed to \
3be usable on many operating systems. The goal of the project \
4is to make it easy for free software authors to make their \
5software run on many operating systems. Since source is designed \
6to be copied from gnulib, it is not a library per-se, as much \
7as a collection of portable idioms to be used in other projects."
8
9HOMEPAGE = "http://www.gnu.org/software/gnulib/"
10SECTION = "devel"
11LICENSE = "LGPL-2.0-or-later"
12
13LIC_FILES_CHKSUM = "file://COPYING;md5=56a22a6e5bcce45e2c8ac184f81412b5"
14SRCREV = "c99c8d491850dc3a6e0b8604a2729d8bc5c0eff1"
15
16SRC_URI = "git://git.savannah.gnu.org/git/gnulib.git;branch=stable-${PV};protocol=https \
17"
18
19S = "${WORKDIR}/git"
20
21do_install () {
22    install -d ${D}/${datadir}/gnulib
23    cp --no-preserve=ownership --recursive ${S}/* ${D}/${datadir}/gnulib/
24    cp --no-preserve=ownership --recursive ${S}/.git ${D}/${datadir}/gnulib/
25}
26
27do_patch[noexec] = "1"
28do_configure[noexec] = "1"
29do_compile[noexec] = "1"
30do_package[noexec] = "1"
31do_packagedata[noexec] = "1"
32deltask package_write_ipk
33deltask package_write_deb
34deltask package_write_rpm
35deltask do_deploy_archives
36
37BBCLASSEXTEND = "native"
38