1SUMMARY = "gd is a library used to create PNG, JPEG, or WBMP images"
2DESCRIPTION = "The gd graphics library allows your code to quickly draw images \
3complete with lines, arcs, text, multiple colors, cut and paste from other \
4images, and flood fills, and to write out the result as a PNG or JPEG file. \
5This is particularly useful in Web applications, where PNG and JPEG are two \
6of the formats accepted for inline images by most browsers. Note that gd is not \
7a paint program."
8HOMEPAGE = "http://libgd.github.io/"
9
10SECTION = "libs"
11LICENSE = "GD"
12LIC_FILES_CHKSUM = "file://COPYING;md5=ace63adfdac78400fc30fa22ee9c1bb1"
13
14DEPENDS = "freetype libpng jpeg zlib tiff"
15
16SRC_URI = "git://github.com/libgd/libgd.git;nobranch=1;protocol=https \
17           "
18
19SRCREV = "b5319a41286107b53daa0e08e402aa1819764bdc"
20
21S = "${WORKDIR}/git"
22
23inherit autotools binconfig gettext pkgconfig
24
25EXTRA_OECONF += " --disable-rpath \
26                  --with-jpeg=${STAGING_LIBDIR}/.. \
27                  --with-freetype=yes \
28                  --without-fontconfig \
29                  --without-webp \
30                  --without-xpm \
31                  --without-x \
32                "
33
34EXTRA_OEMAKE = 'LDFLAGS="${LDFLAGS}"'
35
36DEBUG_OPTIMIZATION:append = " -Wno-error=maybe-uninitialized"
37
38do_install:append:class-target() {
39    # cleanup buildpaths from gdlib.pc
40    sed -i -e 's#${STAGING_DIR_HOST}##g' ${D}${libdir}/pkgconfig/gdlib.pc
41}
42
43PACKAGES += "${PN}-tools"
44
45FILES:${PN} = "${libdir}/lib*${SOLIBS}"
46FILES:${PN}-tools = "${bindir}/*"
47
48PROVIDES += "${PN}-tools"
49RPROVIDES:${PN}-tools = "${PN}-tools"
50RDEPENDS:${PN}-tools = "perl perl-module-strict"
51
52CVE_PRODUCT = "libgd"
53
54BBCLASSEXTEND = "native nativesdk"
55