1SUMMARY = "open-source formatting library for C++"
2DESCRIPTION = "{fmt} is an open-source formatting library for C++. It can be used as a safe and fast alternative to (s)printf and iostreams."
3HOMEPAGE = "https://fmt.dev"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=b9257785fc4f3803a4b71b76c1412729"
6
7SRC_URI = "git://github.com/fmtlib/fmt;branch=10.x;protocol=https"
8SRCREV = "e69e5f977d458f2650bb346dadf2ad30c5320281"
9
10S = "${WORKDIR}/git"
11
12inherit cmake
13
14EXTRA_OECMAKE += "-DBUILD_SHARED_LIBS=ON"
15
16BBCLASSEXTEND = "native nativesdk"
17