1SUMMARY = "Default display timings and resolutions for fbset"
2HOMEPAGE = "http://users.telenet.be/geertu/Linux/fbdev/"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
5
6PV = "0.1.0"
7
8SRC_URI = "file://fb.modes"
9S = "${WORKDIR}"
10
11do_install() {
12    install -d ${D}${sysconfdir}
13    install -m 0644 ${WORKDIR}/fb.modes ${D}${sysconfdir}
14}
15
16# fb.modes file is MACHINE_ARCH, base.bbclass correctly changes it to MACHINE_ARCH, but too late for allarch.bbclass
17# to disable "all" behavior (found when comparing qemuarm and qemux86 signatures)
18PACKAGE_ARCH = "${MACHINE_ARCH}"
19
20CONFFILES:${PN} = "${sysconfdir}/fb.modes"
21