1SUMMARY = "Exif, Iptc and XMP metadata manipulation library and tools"
2LICENSE = "GPL-2.0-only"
3LIC_FILES_CHKSUM = "file://COPYING;md5=625f055f41728f84a8d7938acc35bdc2"
4
5DEPENDS = "zlib expat brotli libinih"
6
7SRC_URI = "https://github.com/Exiv2/${BPN}/releases/download/v${PV}/${BP}-Source.tar.gz"
8SRC_URI[sha256sum] = "89af3b5ef7277753ef7a7b5374ae017c6b9e304db3b688f1948e73e103491f3d"
9# Once patch is obsolete (project should be aware due to PRs), dos2unix can be removed either
10# inherit dos2unix
11S = "${WORKDIR}/${BP}-Source"
12
13inherit cmake gettext
14
15do_install:append:class-target() {
16    # reproducibility: remove build host path
17    sed -i ${D}${libdir}/cmake/exiv2/exiv2Config.cmake \
18        -e 's:${STAGING_DIR_HOST}::g'
19}
20