1require dfu-util_${PV}.bb
2
3inherit deploy native
4
5DEPENDS = "libusb1-native"
6
7PACKAGECONFIG ??= ""
8
9PACKAGECONFIG[static] = "CFLAGS='${CFLAGS} -pthread -static',,"
10
11do_deploy() {
12    install -m 0755 src/dfu-util ${DEPLOYDIR}/dfu-util-${PV}
13    rm -f ${DEPLOYDIR}/dfu-util
14    ln -sf ./dfu-util-${PV} ${DEPLOYDIR}/dfu-util
15}
16
17addtask deploy before do_package after do_install
18
19# cleandirs should possibly be in deploy.bbclass but we need it
20do_deploy[cleandirs] = "${DEPLOYDIR}"
21# clear stamp-extra-info since MACHINE_ARCH is normally put there by
22# deploy.bbclass
23do_deploy[stamp-extra-info] = ""
24
25