1SUMMARY = "DJB daemontools"
2HOMEPAGE = "http://cr.yp.to/daemontools.html"
3DESCRIPTION = "supervise monitors a service. It starts the service and restarts the \
4service if it dies. The companion svc program stops, pauses, or restarts \
5the service on sysadmin request. The svstat program prints a one-line \
6status report. \
7multilog saves error messages to one or more logs.  It optionally timestamps \
8each line and, for each log, includes or excludes lines matching specified \
9patterns.  It automatically rotates logs to limit the amount of disk space \
10used.  If the disk fills up, it pauses and tries again, without losing any \
11data."
12
13SECTION = "System/Servers"
14
15LIC_FILES_CHKSUM = "file://src/prot.c;beginline=1;endline=1;md5=96964cadf07e8f8c1e2ffb3b507dd647"
16LICENSE = "PD"
17
18SRC_URI = "http://cr.yp.to/daemontools/${BPN}-${PV}.tar.gz \
19    file://0001-error.h-include-errno.h-instead-of-extern-int.diff \
20    file://0002-supervise.c-.-supervise-may-be-a-symlink-if-it-s-da.diff \
21    file://cross-compile.patch \
22    file://0001-daemontools-Fix-QA-Issue.patch \
23"
24
25SRC_URI[md5sum] = "1871af2453d6e464034968a0fbcb2bfc"
26SRC_URI[sha256sum] = "a55535012b2be7a52dcd9eccabb9a198b13be50d0384143bd3b32b8710df4c1f"
27
28S = "${WORKDIR}/admin/${BP}"
29
30do_compile() {
31    ./package/compile
32}
33
34do_install() {
35    install -d ${D}/${bindir}
36}
37
38do_install:append:class-target() {
39    install -m755 ${S}/command/* ${D}/${bindir}
40}
41
42inherit update-alternatives
43ALTERNATIVE_PRIORITY = "100"
44ALTERNATIVE:${PN} = "svc svok"
45