1SUMMARY = "copy-paste for the Linux console"
2DESCRIPTION = "Consolation is a daemon that provides copy-paste and scrolling \
3support to the Linux console. It is based on the libinput library and \
4supports all pointer devices and settings provided by this library. Similar \
5software include gpm and jamd."
6HOMEPAGE = "https://salsa.debian.org/consolation-team/consolation"
7SECTION = "console/utils"
8LICENSE = "GPL-2.0-or-later"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=7df9eea2f4dfdda489c116099e6fc062"
10
11DEPENDS = " \
12    libevdev \
13    libinput \
14    udev \
15"
16
17SRC_URI = "git://salsa.debian.org/consolation-team/consolation.git;branch=master"
18SRCREV = "5ef08f0cd6ede62de14de477b74fc3611108c676"
19
20S = "${WORKDIR}/git"
21
22inherit autotools pkgconfig systemd
23
24do_install:append() {
25    install -d ${D}${systemd_system_unitdir}
26    install -m 644 ${B}/consolation.service ${D}${systemd_system_unitdir}
27}
28
29SYSTEMD_SERVICE:${PN} = "consolation.service"
30