1require ${BPN}.inc
2
3inherit meson gobject-introspection gsettings gettext bash-completion systemd features_check useradd
4
5# polkit and gobject-introspection are mandatory and cannot be configured
6REQUIRED_DISTRO_FEATURES = "polkit gobject-introspection-data"
7UNKNOWN_CONFIGURE_WHITELIST:append = " introspection"
8
9DEPENDS += " \
10    ${BPN}-native \
11    glib-2.0 \
12    lcms \
13    sqlite3 \
14    libgusb \
15    libgudev \
16    polkit \
17"
18
19SRC_URI += " \
20    file://0001-Run-native-cd_idt8-cd_create_profile.patch \
21"
22
23EXTRA_OEMESON = " \
24    -Dman=false \
25    -Ddocs=false \
26"
27
28PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
29PACKAGECONFIG[systemd] = "-Dsystemd=true, -Dsystemd=false, systemd"
30
31SYSTEMD_SERVICE:${PN} = "colord.service"
32
33FILES:${PN} += " \
34    ${datadir}/dbus-1 \
35    ${datadir}/polkit-1 \
36    ${datadir}/glib-2.0 \
37    ${datadir}/color \
38    ${systemd_user_unitdir} \
39    ${nonarch_libdir}/tmpfiles.d \
40    ${libdir}/colord-plugins \
41    ${libdir}/colord-sensors \
42"
43
44USERADD_PACKAGES = "${PN}"
45USERADD_PARAM:${PN} = "--system --user-group -d /var/lib/colord -s /bin/false colord"
46