1SUMMARY = "Gesture Recognition And Instantiation Library"
2
3HOMEPAGE = "https://launchpad.net/grail"
4
5LICENSE = "GPLv3 & LGPLv3"
6LIC_FILES_CHKSUM = " \
7    file://COPYING;md5=e6a600fd5e1d9cbde2d983680233ad02 \
8    file://COPYING.GPL3;md5=d32239bcb673463ab874e80d47fae504 \
9"
10
11inherit autotools pkgconfig
12
13DEPENDS = "frame"
14CXXFLAGS:append:toolchain-clang = " -Wno-pessimizing-move"
15SRC_URI = "https://launchpad.net/${BPN}/trunk/${PV}/+download/${BPN}-${PV}.tar.bz2"
16
17UPSTREAM_CHECK_URI = "https://launchpad.net/grail/trunk"
18
19SRC_URI[md5sum] = "0df1b3ec6167920f310e2effe6e2ad44"
20SRC_URI[sha256sum] = "5eed1f650f042481daa3a2de5e7d43261fe343b2a1b1e240f3b7fc26572c9df3"
21
22PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}"
23PACKAGECONFIG[x11] = "--with-x11, --without-x11, libxi"
24
25PACKAGE_BEFORE_PN += "${PN}-test"
26FILES:${PN}-test = "${bindir}/grail-test*"
27SECURITY_CFLAGS = "${SECURITY_NO_PIE_CFLAGS}"
28