1SUMMARY = "An implementation of the GEIS interface"
2DESCRIPTION = "An implementation of the GEIS (Gesture Engine Interface and Support) \
3interface\
4GEIS is a library for applications and toolkit programmers which \
5provides a consistent platform independent interface for any \
6system-wide input gesture recognition mechanism."
7
8HOMEPAGE = "https://launchpad.net/geis"
9
10LICENSE = "GPLv3 & LGPLv3"
11LIC_FILES_CHKSUM = " \
12    file://COPYING;md5=6a6a8e020838b23406c81b19c1d46df6 \
13    file://COPYING.GPL;md5=f27defe1e96c2e1ecd4e0c9be8967949 \
14"
15
16inherit autotools pkgconfig python3native lib_package features_check
17
18REQUIRED_DISTRO_FEATURES = "x11"
19
20DEPENDS += "grail dbus-glib python3 virtual/libx11 libxext libxi libxcb dbus frame"
21
22SRC_URI = "https://launchpad.net/${BPN}/trunk/${PV}/+download/${BPN}-${PV}.tar.xz \
23           file://fix-indentation-for-gcc6.patch \
24           file://0001-libgeis-Compare-the-first-character-of-string-to-nul.patch \
25           "
26
27UPSTREAM_CHECK_URI = "https://launchpad.net/geis/trunk"
28
29SRC_URI[md5sum] = "2ff9d76a3ea5794516bb02c9d1924faf"
30SRC_URI[sha256sum] = "8a60f5683852094038904e690d23cc5a90a980fc52da67f0f28890baa25c70eb"
31
32EXTRA_OECONF = "--disable-integration-tests"
33
34FILES_${PN}-bin = "${bindir}"
35RDEPENDS_${PN}-bin = " \
36    python3-compression \
37    python3-core \
38    python3-crypt \
39    python3-ctypes \
40    python3-fcntl \
41    python3-misc \
42    python3-pickle \
43    python3-shell \
44    python3-stringold \
45    python3-threading \
46"
47
48FILES_${PN} += " \
49    ${datadir}/geisview \
50    ${libdir}/${PYTHON_DIR}/site-packages/geis* \
51    ${libdir}/${PYTHON_DIR}/site-packages/_*.so \
52"
53
54FILES_${PN}-dbg += "${libdir}/${PYTHON_DIR}/site-packages/.debug"
55
56FILES_${PN}-dev += "${libdir}/${PYTHON_DIR}/site-packages/_*.la"
57
58FILES_${PN}-staticdev += "${libdir}/${PYTHON_DIR}/site-packages/_*.a"
59