1SUMMARY = "C-Periphery lib used to access GPIO, LED, PWM, SPI, I2C, MMIO, Serial"
2DESCRIPTION = "A C library for peripheral I/O (GPIO, LED, PWM, SPI, I2C, MMIO, Serial) in Linux"
3
4HOMEPAGE = "https://github.com/vsergeev/c-periphery"
5
6SECTION = "libs"
7
8LICENSE = "MIT"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=be30d45bdc453f70a494c149c2168289"
10
11SRC_URI = "git://github.com/vsergeev/c-periphery;protocol=https;branch=master"
12SRCREV = "91f9678d2a35a3af3c633f20165bdde8bea32209"
13
14S = "${WORKDIR}/git"
15
16inherit cmake
17
18EXTRA_OECMAKE = "-DBUILD_SHARED_LIBS=ON"
19
20BBCLASSEXTEND = "native nativesdk"
21
22