1SUMMARY = "Asio is C++ library for network and low-level I/O programming"
2DESCRIPTION = "Asio is a cross-platform C++ library for network and low-level \
3        I/O programming that provides developers with a consistent asynchronous \
4        model using a modern C++ approach."
5HOMEPAGE = "http://think-async.com/Asio"
6SECTION = "libs"
7LICENSE = "BSL-1.0"
8
9DEPENDS = "openssl"
10
11SRC_URI = " \
12    ${SOURCEFORGE_MIRROR}/asio/${BP}.tar.bz2 \
13    file://0001-Add-the-pkgconfigdir-location.patch \
14"
15
16inherit autotools
17
18ALLOW_EMPTY:${PN} = "1"
19
20LIC_FILES_CHKSUM = "file://COPYING;md5=ff668366bbdb687b6029d33a5fe4b999"
21
22SRC_URI[sha256sum] = "d0ddc2361abd2f4c823e970aaf8e28b4b31ab21b1a68af16b114fc093661e232"
23
24PACKAGECONFIG ??= "boost"
25
26PACKAGECONFIG[boost] = "--with-boost=${STAGING_LIBDIR},--without-boost,boost"
27
28BBCLASSEXTEND = "native nativesdk"
29