1SUMMARY = "TOMOYO Linux tools"
2DESCRIPTION = "TOMOYO Linux is a Mandatory Access Control (MAC) implementation \
3for Linux that can be used to increase the security of a system, while also \
4being useful purely as a system analysis tool."
5HOMEPAGE = "http://tomoyo.sourceforge.jp/"
6SECTION = "System Environment/Kernel"
7
8SRC_URI = "http://jaist.dl.sourceforge.jp/tomoyo/70710/${BP}-20210910.tar.gz"
9SRC_URI[sha256sum] = "47a12cdb1fe7bbd0b2e3486150fe1e754fa9c869aeefd42fd311c4022b78010a"
10
11S = "${WORKDIR}/${BPN}"
12
13LICENSE = "GPL-2.0-only"
14LIC_FILES_CHKSUM = "file://COPYING.tomoyo;md5=751419260aa954499f7abaabaa882bbe"
15
16FILES:${PN}     += "${libdir}/tomoyo"
17FILES:${PN}-dbg += "${libdir}/tomoyo/.debug"
18
19DEPENDS = "linux-libc-headers ncurses"
20
21EXTRA_OEMAKE = "-e USRLIBDIR=${libdir}"
22
23do_compile () {
24    oe_runmake 'CC=${CC}'
25}
26
27do_install() {
28    oe_runmake install SBINDIR=${base_sbindir} INSTALLDIR=${D}
29}
30