1SUMMARY = "PKCS#11 HSM/Token Emulator"
2HOMEPAGE = "https://www.opendnssec.org/softhsm/"
3LICENSE = "BSD-2-Clause & ISC"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=ef3f77a3507c3d91e75b9f2bdaee4210"
5
6DEPENDS = "sqlite3"
7
8SRC_URI = "https://dist.opendnssec.org/source/softhsm-2.6.1.tar.gz \
9           file://0001-avoid-unnecessary-check-for-sqlite3-binary.patch \
10           file://0002-Prevent-accessing-of-global-c-objects-once-they-are-.patch \
11"
12SRC_URI[sha256sum] = "61249473054bcd1811519ef9a989a880a7bdcc36d317c9c25457fc614df475f2"
13
14inherit autotools pkgconfig siteinfo
15
16EXTRA_OECONF += " --with-sqlite3=${STAGING_DIR_HOST}/usr"
17EXTRA_OECONF += " --with-objectstore-backend-db"
18EXTRA_OECONF += "${@oe.utils.conditional('SITEINFO_BITS', '64', ' --enable-64bit', '', d)}"
19
20PACKAGECONFIG ?= "ecc eddsa pk11 openssl"
21
22PACKAGECONFIG[npm] = ",--disable-non-paged-memory"
23PACKAGECONFIG[ecc] = "--enable-ecc,--disable-ecc"
24PACKAGECONFIG[gost] = "--enable-gost,--disable-gost"
25PACKAGECONFIG[eddsa] = "--enable-eddsa, --disable-eddsa"
26PACKAGECONFIG[fips] = "--enable-fips, --disable-fips"
27PACKAGECONFIG[notvisable] = "--disable-visibility"
28PACKAGECONFIG[openssl] = "--with-openssl=${STAGING_DIR_HOST}/usr --with-crypto-backend=openssl, --without-openssl, openssl, openssl"
29PACKAGECONFIG[botan] = "--with-botan=${STAGING_DIR_HOST}/usr --with-crypto-backend=botan, --without-botan, botan"
30PACKAGECONFIG[migrate] = "--with-migrate"
31PACKAGECONFIG[pk11] = "--enable-p11-kit --with-p11-kit=${datadir}/p11-kit/modules, --without-p11-kit, p11-kit, p11-kit"
32
33FILES:${PN} += "${@bb.utils.contains('PACKAGECONFIG', 'pk11', '${datadir}/p11-kit/modules/softhsm2.module', '', d)}"
34
35RDEPENDS:${PN} = "sqlite3"
36BBCLASSEXTEND = "native nativesdk"
37