1SUMMARY = "network auditing tool"
2DESCRIPTION = "Nmap ("Network Mapper") is a free and open source (license) utility for network discovery and security auditing.\nGui support via appending to IMAGE_FEATURES x11-base in local.conf"
3SECTION = "security"
4LICENSE = "GPL-2.0"
5
6LIC_FILES_CHKSUM = "file://COPYING;beginline=7;endline=12;md5=66938a7e5b4c118eda78271de14874c2"
7
8SRC_URI = "http://nmap.org/dist/${BP}.tar.bz2 \
9           file://nmap-redefine-the-python-library-dir.patch \
10           file://nmap-replace-shtool-mkdir-with-coreutils-mkdir-command.patch \
11           file://0001-Include-time.h-header-to-pass-clang-compilation.patch \
12           file://0002-Fix-building-with-libc.patch \
13           "
14
15SRC_URI[md5sum] = "d37b75b06d1d40f27b76d60db420a1f5"
16SRC_URI[sha256sum] = "fcfa5a0e42099e12e4bf7a68ebe6fde05553383a682e816a7ec9256ab4773faa"
17
18inherit autotools-brokensep pkgconfig pythonnative
19
20PACKAGECONFIG ?= "ncat nping ndiff pcap"
21
22PACKAGECONFIG[pcap] = "--with-pcap=linux, --without-pcap, libpcap, libpcap"
23PACKAGECONFIG[pcre] = "--with-libpcre=${STAGING_LIBDIR}/.., --with-libpcre=included, libpcre"
24PACKAGECONFIG[ssl] = "--with-openssl=${STAGING_LIBDIR}/.., --without-openssl, openssl, openssl"
25PACKAGECONFIG[ssh2] = "--with-openssh2=${STAGING_LIBDIR}/.., --without-openssh2, libssh2, libssh2"
26PACKAGECONFIG[libz] = "--with-libz=${STAGING_LIBDIR}/.., --without-libz, zlib, zlib"
27
28#disable/enable packages
29PACKAGECONFIG[nping] = ",--without-nping,"
30PACKAGECONFIG[ncat] = ",--without-ncat,"
31PACKAGECONFIG[ndiff] = ",--without-ndiff,python"
32PACKAGECONFIG[update] = ",--without-nmap-update,"
33
34EXTRA_OECONF = "--with-libdnet=included --with-liblinear=included --without-subversion --with-liblua=included"
35
36# zenmap needs python-pygtk which has been removed
37# it also only works with python2
38# disable for now until py3 is supported
39EXTRA_OECONF += "--without-zenmap"
40
41export PYTHON_SITEPACKAGES_DIR
42
43do_configure() {
44    autoconf
45    install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.guess ${S}
46    install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.sub ${S}
47    oe_runconf
48}
49
50FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR} ${datadir}/ncat"
51
52RDEPENDS_${PN} = "python"
53