1DESCRIPTION = "Library extending the SQLite core to support fully fledged Spatial SQL capabilities"
2HOMEPAGE = "https://www.gaia-gis.it/fossil/libspatialite/"
3SECTION = "libs"
4DEPENDS = "proj geos sqlite3 libxml2 zlib"
5
6LICENSE = "MPL-1.1 & GPL-2.0-or-later & LGPL-2.1-or-later"
7LIC_FILES_CHKSUM = "file://COPYING;md5=0e92e1a36cc384b60f5b31dde0bdd39e"
8
9SRC_URI = "http://www.gaia-gis.it/gaia-sins/libspatialite-sources/libspatialite-${PV}.tar.gz \
10           file://libspatialite_geos.patch \
11           file://libspatialite_macros.patch \
12           file://libspatialite_pkgconfig.patch \
13"
14
15SRC_URI[sha256sum] = "eecbc94311c78012d059ebc0fae86ea5ef6eecb13303e6e82b3753c1b3409e98"
16
17inherit autotools-brokensep pkgconfig
18
19EXTRA_OECONF = "--enable-freexl=no --disable-rttopo --disable-minizip"
20
21# package plugins for SQLite3
22PACKAGES += "${PN}-plugin"
23INSANE_SKIP:${PN}-plugin = "dev-so"
24FILES:${PN}-plugin += "${libdir}/mod_*"
25