1DESCRIPTION = "PulseAudio Volume Control (pavucontrol) is a simple GTK based volume control tool ("mixer") for the PulseAudio sound server."
2HOMEPAGE = "https://freedesktop.org/software/pulseaudio/pavucontrol/"
3SECTION = "x11/multimedia"
4LICENSE = "GPL-2.0-or-later"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=751419260aa954499f7abaabaa882bbe"
6
7# glib-2.0-native is required for glib-gettextize, which is used by the
8# AM_GLIB_GNU_GETTEXT macro in configure.ac. That macro is deprecated, so the
9# glib-2.0-native dependency may go away at some point (something to keep in
10# mind when doing version upgrades).
11DEPENDS = "libxml-parser-perl-native intltool-native glib-2.0-native gtkmm3 pulseaudio json-glib"
12
13inherit autotools features_check perlnative pkgconfig
14
15ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
16
17SRC_URI = "http://freedesktop.org/software/pulseaudio/${BPN}/${BP}.tar.xz"
18SRC_URI:append = " ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'file://0001-pavucontrol-remove-canberra-gtk-support.patch', '', d)}"
19
20SRC_URI[sha256sum] = "ce2b72c3b5f1a70ad0df19dd81750f9455bd20870d1d3a36d20536af2e8f4e7a"
21
22PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}"
23PACKAGECONFIG[x11] = ",,libcanberra"
24
25EXTRA_OECONF = "--disable-lynx "
26
27RDEPENDS:${PN} += "pulseaudio-server"
28