1SUMMARY = "Library for reading mod-like audio files"
2HOMEPAGE = "http://modplug-xmms.sf.net"
3
4LICENSE = "PD"
5LIC_FILES_CHKSUM = "file://COPYING;md5=c9182faa1f7c316f7b97d404bcbe3685"
6
7SRC_URI = "${SOURCEFORGE_MIRROR}/modplug-xmms/libmodplug-${PV}.tar.gz \
8           file://0001-fastmix-Drop-register-storage-class-keyword.patch"
9
10SRC_URI[sha256sum] = "457ca5a6c179656d66c01505c0d95fafaead4329b9dbaa0f997d00a3508ad9de"
11
12inherit autotools pkgconfig
13
14EXTRA_OECONF = "--disable-option-checking"
15
16# NOTE: autotools_stage_all does nothing here, we need to do it manually
17do_install:append() {
18    install -d ${D}${includedir}/libmodplug
19    install -m 0644 ${S}/src/modplug.h ${D}${includedir}/libmodplug
20    install -m 0644 ${S}/src/modplug.h ${D}${includedir}/
21}
22