1SUMMARY = "MMS stream protocol library"
2HOMEPAGE = "http://sourceforge.net/projects/libmms/"
3SECTION = "libs/multimedia"
4
5LICENSE = "LGPL-2.0-or-later"
6LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=fad9b3332be894bab9bc501572864b29"
7
8SRC_URI = "${SOURCEFORGE_MIRROR}/project/${BPN}/${BPN}/${PV}/${BP}.tar.gz"
9SRC_URI[md5sum] = "d6b665b335a6360e000976e770da7691"
10SRC_URI[sha256sum] = "3c05e05aebcbfcc044d9e8c2d4646cd8359be39a3f0ba8ce4e72a9094bee704f"
11
12inherit autotools pkgconfig
13
14do_install:append() {
15    # The GLib dependency was removed in libmms 0.6.3, but the
16    # "Requires" was not removed from the pkg-config file.  Since we
17    # don't have (and don't want) the RDEPENDS on GLib, we should
18    # remove the "Requires" line.
19    sed -i '/^Requires: glib-2\.0$/d' ${D}${libdir}/pkgconfig/libmms.pc
20}
21