1DESCRIPTION = "jackdmp is a C++ version of the JACK low-latency audio \
2server for multi-processor machines. It is a new implementation of the \
3JACK server core features that aims in removing some limitations of \
4the JACK1 design. The activation system has been changed for a data \
5flow model and lock-free programming techniques for graph access have \
6been used to have a more dynamic and robust system."
7SECTION = "libs/multimedia"
8
9LICENSE = "GPL-2.0-only & GPL-2.0-or-later & LGPL-2.1-or-later"
10LIC_FILES_CHKSUM = " \
11    file://common/JackControlAPI.cpp;beginline=5;endline=19;md5=9d1921199e203163f160313243f853d6 \
12    file://common/JackControlAPI.h;beginline=4;endline=18;md5=9d1921199e203163f160313243f853d6 \
13    file://common/jack/jack.h;beginline=2;endline=17;md5=0a668d22ce661159cad28d1c3b8e66af \
14    file://common/JackServer.h;beginline=2;endline=17;md5=9bf0870727804a994ee2d19fd368d940 \
15"
16
17DEPENDS = "libsamplerate0 libsndfile1"
18
19SRC_URI = "git://github.com/jackaudio/jack2.git;branch=master;protocol=https \
20    file://0001-Conceal-imp-warnings-in-Python3.patch \
21    file://0002-Fix-all-DeprecationWarning-invalid-escape-sequence.patch \
22"
23SRCREV = "4f58969432339a250ce87fe855fb962c67d00ddb"
24
25UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)"
26
27S = "${WORKDIR}/git"
28
29inherit waf pkgconfig
30
31PACKAGECONFIG ??= "alsa"
32PACKAGECONFIG[alsa] = "--alsa=yes,--alsa=no,alsa-lib"
33# --dbus only stops building jackd -> add --classic
34PACKAGECONFIG[dbus] = "--dbus --classic,,dbus"
35PACKAGECONFIG[opus] = "--opus=yes,--opus=no,libopus"
36
37# portaudio is for windows builds only
38EXTRA_OECONF = "--portaudio=no"
39
40do_install:append() {
41	if ! ${@bb.utils.contains('PACKAGECONFIG', 'dbus', True, False, d)}; then
42		rm -f ${D}${bindir}/jack_control
43	fi
44}
45
46PACKAGES =+ "libjack jack-server jack-utils"
47
48RDEPENDS:jack-dev:remove = "${PN} (= ${EXTENDPKGV})"
49
50FILES:libjack = "${libdir}/*.so.* ${libdir}/jack/*.so"
51FILES:jack-server = " \
52    ${datadir}/dbus-1/services \
53    ${bindir}/jackdbus \
54    ${bindir}/jackd \
55"
56FILES:jack-utils = "${bindir}/*"
57
58FILES:${PN}-doc += " ${datadir}/jack-audio-connection-kit/reference/html/*"
59
60