1SUMMARY = "Library for interacting with ID3 tags"
2SECTION = "libs/multimedia"
3LICENSE = "LGPLv2+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7"
5DEPENDS = "zlib"
6
7PR = "r1"
8
9SRC_URI = "${SOURCEFORGE_MIRROR}/id3lib/id3lib-${PV}.tar.gz;name=archive \
10           ${DEBIAN_MIRROR}/main/i/id3lib3.8.3/id3lib3.8.3_3.8.3-16.2.debian.tar.xz;name=patch;subdir=${BP} \
11           file://acdefine.patch \
12"
13SRC_URI[archive.md5sum] = "19f27ddd2dda4b2d26a559a4f0f402a7"
14SRC_URI[archive.sha256sum] = "2749cc3c0cd7280b299518b1ddf5a5bcfe2d1100614519b68702230e26c7d079"
15SRC_URI[patch.md5sum] = "997c764d3be11c9a51779d93facf1118"
16SRC_URI[patch.sha256sum] = "ac2ee23ec89ba2af51d2c6dd5b1b6bf9f8a9f813de251bc182941439a4053176"
17
18inherit autotools
19
20# Unlike other Debian packages, id3lib*.diff.gz contains another series of
21# patches maintained by quilt. So manually apply them before applying other local
22# patches. Also remove all temp files before leaving, because do_patch() will pop
23# up all previously applied patches in the start
24do_patch[depends] += "quilt-native:do_populate_sysroot"
25id3lib_do_patch() {
26    cd ${S}
27    # it's important that we only pop the existing patches when they've
28    # been applied, otherwise quilt will climb the directory tree
29    # and reverse out some completely different set of patches
30    if [ -d ${S}/patches ]; then
31        # whilst this is the default directory, doing it like this
32        # defeats the directory climbing that quilt will otherwise
33        # do; note the directory must exist to defeat this, hence
34        # the test inside which we operate
35        QUILT_PATCHES=${S}/patches quilt pop -a
36    fi
37    if [ -d ${S}/.pc-${BPN} ]; then
38        rm -rf ${S}/.pc
39        mv ${S}/.pc-${BPN} ${S}/.pc
40        QUILT_PATCHES=${S}/debian/patches quilt pop -a
41        rm -rf ${S}/.pc ${S}/debian
42    fi
43    QUILT_PATCHES=${S}/debian/patches quilt push -a
44    mv ${S}/.pc ${S}/.pc-${BPN}
45}
46
47do_unpack[cleandirs] += "${S}"
48
49# We invoke base do_patch at end, to incorporate any local patch
50python do_patch() {
51    bb.build.exec_func('id3lib_do_patch', d)
52    bb.build.exec_func('patch_do_patch', d)
53}
54