1SUMMARY = "CD/DVD command line tools"
2HOMEPAGE = "http://cdrkit.org/"
3
4LICENSE = "GPL-2.0-only"
5LIC_FILES_CHKSUM = "file://COPYING;md5=b30d3b2750b668133fc17b401e1b98f8"
6
7# While writing download from cdrkit.org was broken so get sources from debian
8SRC_URI = "${DEBIAN_MIRROR}/main/c/${BPN}/${BPN}_${PV}.orig.tar.gz \
9           file://0001-do-not-create-a-run-test-to-determine-order-of-bitfi.patch \
10           file://0001-genisoimage-Fix-fprintf-format-errors.patch \
11           file://0001-define-__THROW-to-avoid-build-issue-with-musl.patch \
12           file://0002-Do-not-use-rcmd-on-build-with-musl.patch \
13           file://0001-genisoimage-Add-missing-extern-definition.patch \
14           file://0001-add-new-option-eltorito-platform.patch \
15           "
16SRC_URI:append:class-nativesdk = " \
17           file://0001-install-netscsid-to-bin-for-nativesdk.patch \
18"
19SRC_URI[md5sum] = "efe08e2f3ca478486037b053acd512e9"
20SRC_URI[sha256sum] = "d1c030756ecc182defee9fe885638c1785d35a2c2a297b4604c0e0dcc78e47da"
21
22inherit cmake
23
24DEPENDS = "libcap file bzip2"
25RDEPENDS:dirsplit = "perl"
26
27RDEPENDS:${PN}-dev = ""
28
29PACKAGES =+ "dirsplit genisoimage icedax wodim"
30
31FILES:dirsplit = " \
32    ${bindir}/dirsplit \
33"
34
35FILES:genisoimage = " \
36    ${bindir}/devdump \
37    ${bindir}/genisoimage \
38    ${bindir}/isodebug \
39    ${bindir}/isodump \
40    ${bindir}/isoinfo \
41    ${bindir}/isovfy \
42    ${bindir}/mkisofs \
43"
44
45FILES:icedax = " \
46    ${bindir}/cdda2mp3 \
47    ${bindir}/cdda2ogg \
48    ${bindir}/icedax \
49    ${bindir}/pitchplay \
50    ${bindir}/readmult \
51"
52
53FILES:wodim = " \
54    ${bindir}/readom \
55    ${bindir}/wodim \
56    ${sbindir}/netscsid \
57"
58
59do_install:append() {
60    ln -sf --relative ${D}${bindir}/genisoimage ${D}${bindir}/mkisofs
61}
62
63BBCLASSEXTEND = "native nativesdk"
64