1SUMMARY = "CD/DVD command line tools"
2HOMEPAGE = "http://cdrkit.org/"
3
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=b30d3b2750b668133fc17b401e1b98f8"
6
7# While writing download from cdrkit.org was broken so get sources from debian
8SRC_URI = "${DEBIAN_MIRROR}/main/c/${BPN}/${BPN}_${PV}.orig.tar.gz \
9           file://0001-do-not-create-a-run-test-to-determine-order-of-bitfi.patch \
10           file://0001-genisoimage-Fix-fprintf-format-errors.patch \
11           file://0001-define-__THROW-to-avoid-build-issue-with-musl.patch \
12           file://0002-Do-not-use-rcmd-on-build-with-musl.patch \
13           file://0001-genisoimage-Add-missing-extern-definition.patch \
14           "
15SRC_URI[md5sum] = "efe08e2f3ca478486037b053acd512e9"
16SRC_URI[sha256sum] = "d1c030756ecc182defee9fe885638c1785d35a2c2a297b4604c0e0dcc78e47da"
17
18inherit cmake
19
20DEPENDS = "libcap file bzip2"
21RDEPENDS_dirsplit = "perl"
22
23PACKAGES =+ "dirsplit genisoimage icedax wodim"
24
25FILES_dirsplit = " \
26    ${bindir}/dirsplit \
27"
28
29FILES_genisoimage = " \
30    ${bindir}/devdump \
31    ${bindir}/genisoimage \
32    ${bindir}/isodebug \
33    ${bindir}/isodump \
34    ${bindir}/isoinfo \
35    ${bindir}/isovfy \
36    ${bindir}/mkisofs \
37"
38
39FILES_icedax = " \
40    ${bindir}/cdda2mp3 \
41    ${bindir}/cdda2ogg \
42    ${bindir}/icedax \
43    ${bindir}/pitchplay \
44    ${bindir}/readmult \
45"
46
47FILES_wodim = " \
48    ${bindir}/readom \
49    ${bindir}/wodim \
50    ${sbindir}/netscsid \
51"
52
53do_install_append() {
54    ln -sf ${bindir}/genisoimage ${D}${bindir}/mkisofs
55}
56
57BBCLASSEXTEND = "native"
58