1SUMMARY  = "Timing analysis tools for suspend/resume/boot"
2DESCRIPTION = "This tool suite is designed to assist kernel and OS developers \
3in optimizing their linux stack's suspend/resume & boot time."
4HOMEPAGE = "https://01.org/pm-graph"
5LICENSE  = "GPL-2.0-only"
6LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e"
7
8SRCREV = "cf59527dc24fdd2f314ae4dcaeb3d68a117988f6"
9SRC_URI = "git://github.com/intel/pm-graph.git;branch=master;protocol=https \
10           file://0001-Makefile-fix-multilib-build-failure.patch \
11           file://0001-sleepgraph.py-use-python3.patch \
12           file://0001-sleepgraph-add-support-for-RT-kernel-ftrace-flags.patch \
13           file://0001-sleepgraph.py-parse-unfished-cpu-exec-line.patch \
14"
15S = "${WORKDIR}/git"
16
17# Apart from the listed RDEPENDS, analyze-suspend depends on some features
18# provided by the kernel. These options are:
19#   - CONFIG_PM_DEBUG=y
20#   - CONFIG_PM_SLEEP_DEBUG=y
21#   - CONFIG_FTRACE=y
22#   - CONFIG_FUNCTION_TRACER=y
23#   - CONFIG_FUNCTION_GRAPH_TRACER=y
24
25COMPATIBLE_HOST='(i.86|x86_64).*'
26EXTRA_OEMAKE = "PREFIX=${prefix} DESTDIR=${D} BASELIB=${baselib}"
27
28do_install() {
29        oe_runmake install
30        install -Dm 0755 ${S}/analyze_suspend.py ${D}${bindir}/analyze_suspend.py
31}
32
33RDEPENDS:${PN} += "python3-core python3-threading python3-datetime python3-compression"
34RPROVIDES:${PN} = "analyze-suspend"
35BBCLASSEXTEND = "native nativesdk"
36