1SUMMARY  = "Timing analysis tools for suspend/resume/boot"
2DESCRIPTION = "This tool suite is designed to assist kernel and OS developers \
3in optimizing their linux stack's suspend/resume & boot time."
4HOMEPAGE = "https://01.org/pm-graph"
5LICENSE  = "GPL-2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e"
7
8SRCREV = "cf59527dc24fdd2f314ae4dcaeb3d68a117988f6"
9SRC_URI = "git://github.com/intel/pm-graph.git \
10           file://0001-Makefile-fix-multilib-build-failure.patch \
11           file://0001-sleepgraph.py-use-python3.patch \
12"
13S = "${WORKDIR}/git"
14
15# Apart from the listed RDEPENDS, analyze-suspend depends on some features
16# provided by the kernel. These options are:
17#   - CONFIG_PM_DEBUG=y
18#   - CONFIG_PM_SLEEP_DEBUG=y
19#   - CONFIG_FTRACE=y
20#   - CONFIG_FUNCTION_TRACER=y
21#   - CONFIG_FUNCTION_GRAPH_TRACER=y
22
23COMPATIBLE_HOST='(i.86|x86_64).*'
24EXTRA_OEMAKE = "PREFIX=${prefix} DESTDIR=${D} BASELIB=${baselib}"
25
26do_install() {
27        oe_runmake install
28        install -Dm 0755 ${S}/analyze_suspend.py ${D}${bindir}/analyze_suspend.py
29}
30
31RDEPENDS_${PN} += "python3-core python3-threading python3-datetime python3-compression"
32RPROVIDES_${PN} = "analyze-suspend"
33BBCLASSEXTEND = "native nativesdk"
34