1SUMMARY = "Kernel selftest for Linux"
2DESCRIPTION = "Kernel selftest for Linux"
3LICENSE = "GPL-2.0-only"
4
5LIC_FILES_CHKSUM = "file://../COPYING;md5=bbea815ee2795b2f4230826c0c6b8814"
6
7DEPENDS = "rsync-native llvm-native"
8
9# for musl libc
10SRC_URI:append:libc-musl = "\
11                      file://userfaultfd.patch \
12                      "
13SRC_URI += "file://run-ptest \
14            file://COPYING \
15            "
16
17# now we just test bpf and vm
18# we will append other kernel selftest in the future
19# bpf was added in 4.10 with: https://github.com/torvalds/linux/commit/5aa5bd14c5f8660c64ceedf14a549781be47e53d
20# if you have older kernel than that you need to remove it from PACKAGECONFIG
21PACKAGECONFIG ??= "firmware"
22# bpf needs working clang compiler anyway
23PACKAGECONFIG:append:toolchain-clang:x86-64 = " bpf"
24PACKAGECONFIG:remove:x86 = "bpf"
25PACKAGECONFIG:remove:arm = "bpf vm"
26# host ptrace.h is used to compile BPF target but mips ptrace.h is needed
27# progs/loop1.c:21:9: error: incomplete definition of type 'struct user_pt_regs'
28# m = PT_REGS_RC(ctx);
29# vm tests need libhugetlbfs starting 5.8+ (https://lkml.org/lkml/2020/4/22/1654)
30PACKAGECONFIG:remove:qemumips = "bpf vm"
31
32# riscv does not support libhugetlbfs yet
33PACKAGECONFIG:remove:riscv64 = "bpf vm"
34PACKAGECONFIG:remove:riscv32 = "bpf vm"
35
36PACKAGECONFIG[bpf] = ",,elfutils elfutils-native libcap libcap-ng rsync-native python3-docutils-native,"
37PACKAGECONFIG[firmware] = ",,libcap, bash"
38PACKAGECONFIG[vm] = ",,libcap libhugetlbfs,libgcc bash"
39
40do_patch[depends] += "virtual/kernel:do_shared_workdir"
41do_compile[depends] += "virtual/kernel:do_install"
42
43inherit linux-kernel-base module-base kernel-arch ptest siteinfo
44
45S = "${WORKDIR}/${BP}"
46
47DEBUG_PREFIX_MAP:remove = "-fcanon-prefix-map"
48
49TEST_LIST = "\
50    ${@bb.utils.filter('PACKAGECONFIG', 'bpf firmware vm', d)} \
51    rtc \
52    ptp \
53    timers \
54"
55EXTRA_OEMAKE = '\
56    CROSS_COMPILE=${TARGET_PREFIX} \
57    ARCH=${ARCH} \
58    CC="${CC}" \
59    AR="${AR}" \
60    LD="${LD}" \
61    CLANG="clang -fno-stack-protector -target ${TARGET_ARCH} ${TOOLCHAIN_OPTIONS} -isystem ${S} -D__WORDSIZE=\'64\' -Wno-error=unused-command-line-argument" \
62    DESTDIR="${D}" \
63    V=1 \
64'
65EXTRA_OEMAKE:append:toolchain-clang = "\
66    LLVM=1 CONFIG_CC_IS_GCC= CONFIG_CC_IS_CLANG=y CONFIG_CC_IMPLICIT_FALLTHROUGH= \
67    HOSTCC="clang -unwindlib=libgcc -rtlib=libgcc -stdlib=libstdc++ ${BUILD_CFLAGS} ${BUILD_LDFLAGS} -Wno-error=unused-command-line-argument" \
68    HOSTLD="clang ${BUILD_LDFLAGS} -unwindlib=libgcc -rtlib=libgcc -stdlib=libstdc++" \
69"
70
71KERNEL_SELFTEST_SRC ?= "Makefile \
72                        include \
73                        kernel \
74                        lib \
75                        tools \
76                        scripts \
77                        arch \
78                        LICENSES \
79"
80do_compile() {
81    if [ ${@bb.utils.contains('PACKAGECONFIG', 'bpf', 'True', 'False', d)} = 'True' ]; then
82    if [ ${@bb.utils.contains('DEPENDS', 'clang-native', 'True', 'False', d)} = 'False' ]; then
83        bbwarn "clang >= 6.0 with bpf support is needed with kernel 4.18+ so
84either install it and add it to HOSTTOOLS, or add clang-native from meta-clang to dependency"
85    fi
86    fi
87    mkdir -p ${S}/include/config ${S}/bits
88    install -Dm 0644 ${STAGING_KERNEL_BUILDDIR}/.config ${S}/include/config/auto.conf
89    if [ "${SITEINFO_BITS}" != "32" ]; then
90        for f in long-double endianness floatn struct_rwlock; do
91            cp ${RECIPE_SYSROOT}${includedir}/bits/$f-64.h ${S}/bits/$f-32.h
92        done
93    fi
94    oe_runmake -C ${S} headers
95    sed -i -e 's|^all: docs|all:|' ${S}/tools/testing/selftests/bpf/Makefile
96    sed -i -e '/mrecord-mcount/d' ${S}/Makefile
97    sed -i -e '/Wno-alloc-size-larger-than/d' ${S}/Makefile
98    sed -i -e '/Wno-alloc-size-larger-than/d' ${S}/scripts/Makefile.*
99    for i in ${TEST_LIST}
100    do
101        oe_runmake -C ${S}/tools/testing/selftests/${i}
102    done
103}
104
105do_install() {
106    for i in ${TEST_LIST}
107    do
108        oe_runmake -C ${S}/tools/testing/selftests/${i} INSTALL_PATH=${D}/usr/kernel-selftest/${i} install
109        # Install kselftest-list.txt that required by kselftest runner.
110        oe_runmake -s --no-print-directory COLLECTION=${i} -C ${S}/tools/testing/selftests/${i} emit_tests \
111            >> ${D}/usr/kernel-selftest/kselftest-list.txt
112    done
113    # Install kselftest runner.
114    install -m 0755 ${S}/tools/testing/selftests/run_kselftest.sh ${D}/usr/kernel-selftest/
115    cp -R --no-dereference --preserve=mode,links -v ${S}/tools/testing/selftests/kselftest ${D}/usr/kernel-selftest/
116    if [ -e ${D}/usr/kernel-selftest/bpf/test_offload.py ]; then
117	sed -i -e '1s,#!.*python3,#! /usr/bin/env python3,' ${D}/usr/kernel-selftest/bpf/test_offload.py
118    fi
119    chown root:root  -R ${D}/usr/kernel-selftest
120}
121
122do_configure() {
123    install -D -m 0644 ${WORKDIR}/COPYING ${S}/COPYING
124}
125
126do_patch[prefuncs] += "copy_kselftest_source_from_kernel remove_unrelated"
127python copy_kselftest_source_from_kernel() {
128    sources = (d.getVar("KERNEL_SELFTEST_SRC") or "").split()
129    src_dir = d.getVar("STAGING_KERNEL_DIR")
130    dest_dir = d.getVar("S")
131    bb.utils.mkdirhier(dest_dir)
132    for s in sources:
133        src = oe.path.join(src_dir, s)
134        dest = oe.path.join(dest_dir, s)
135        if os.path.isdir(src):
136            oe.path.copytree(src, dest)
137        else:
138            bb.utils.copyfile(src, dest)
139}
140
141remove_unrelated() {
142    if ${@bb.utils.contains('PACKAGECONFIG','bpf','true','false',d)} ; then
143        test -f ${S}/tools/testing/selftests/bpf/Makefile && \
144            sed -i -e 's/test_pkt_access.*$/\\/' \
145                   -e 's/test_pkt_md_access.*$/\\/' \
146                   -e 's/sockmap_verdict_prog.*$/\\/' \
147                   ${S}/tools/testing/selftests/bpf/Makefile || \
148            bberror "Your kernel is probably older than 4.10 and doesn't have tools/testing/selftests/bpf/Makefile file from https://github.com/torvalds/linux/commit/5aa5bd14c5f8660c64ceedf14a549781be47e53d, disable bpf PACKAGECONFIG"
149    fi
150}
151
152PACKAGE_ARCH = "${MACHINE_ARCH}"
153
154INHIBIT_PACKAGE_DEBUG_SPLIT="1"
155FILES:${PN} += "/usr/kernel-selftest"
156
157RDEPENDS:${PN} += "python3 perl perl-module-io-handle"
158
159INSANE_SKIP:${PN} += "libdir"
160
161SECURITY_CFLAGS = ""
162COMPATIBLE_HOST:libc-musl = 'null'
163
164# It has native clang/llvm dependency, poky distro is reluctant to include them as deps
165# this helps with world builds on AB
166EXCLUDE_FROM_WORLD = "1"
167