1SUMMARY = "Proxy for UDP/TCP debug connections"
2DESCRIPTION = "The agent-proxy will forward tcp or udp connections as well as allow for script multiplexing of terminal sessions."
3HOMEPAGE = "http://kgdb.wiki.kernel.org/"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a"
6
7SECTION = "devel"
8
9EXTRA_OEMAKE = "'CC=${CC}'"
10
11SRCREV = "468fe4c31e6c62c9bbb328b06ba71eaf7be0b76a"
12
13SRC_URI = "git://git.kernel.org/pub/scm/utils/kernel/kgdb/agent-proxy.git;protocol=git \
14           file://0001-Makefile-Add-LDFLAGS-variable.patch \
15"
16
17BBCLASSEXTEND = "native nativesdk"
18
19S = "${WORKDIR}/git"
20
21do_install () {
22    install -d ${D}${bindir}
23    install -m 0755 agent-proxy ${D}${bindir}
24}
25