1eb8dc403SDave CobbleySUMMARY = "Common X11 scripts and support files"
2eb8dc403SDave CobbleyLICENSE = "GPLv2"
3eb8dc403SDave CobbleyLIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
4eb8dc403SDave Cobbley
5eb8dc403SDave CobbleyPR = "r9"
6eb8dc403SDave Cobbley
7eb8dc403SDave Cobbley# we are using a gpe-style Makefile
88410d61fSBrad Bishopinherit features_check gpe
9eb8dc403SDave Cobbley
10eb8dc403SDave CobbleyREQUIRED_DISTRO_FEATURES = "x11"
11eb8dc403SDave Cobbley
12eb8dc403SDave CobbleySRC_URI[md5sum] = "82f2f84cd96610e8f7b92c700cd31c14"
13eb8dc403SDave CobbleySRC_URI[sha256sum] = "cd04c33418f776b1e13fcc7af3d6bd0c7cccd03fbabd7dbcd97f88166cc34210"
14eb8dc403SDave Cobbley
15*213cb269SPatrick WilliamsSRC_URI:append = " \
16eb8dc403SDave Cobbley    file://0001-COPYING-add-GPLv2-license-file.patch \
17eb8dc403SDave Cobbley    file://0002-add-setdpi-Xinit.d-script.patch \
18eb8dc403SDave Cobbley    file://0006-add-support-for-etc-X11-xserver-system.patch \
19eb8dc403SDave Cobbley    file://0007-use-own-functions-file-instead-etc-init.d-functions.patch \
20eb8dc403SDave Cobbley    file://0008-xserver-common-add-dpi-and-nocursor-params-for-gta01.patch \
21eb8dc403SDave Cobbley    file://0009-xserver-common-add-support-for-n900-alias-nokia_rx-5.patch \
22eb8dc403SDave Cobbley    file://0010-xserver-common-add-support-for-nexus-S-alias-herring.patch \
23eb8dc403SDave Cobbley    file://0011-xserver-common-add-support-for-nexus-one-alias-mahim.patch \
24eb8dc403SDave Cobbley    file://0012-xserver-common-add-support-for-gta04-alias-OpenPhoen.patch \
25eb8dc403SDave Cobbley    file://0013-xserver-common-add-support-for-tuna-alias-Galaxy-Nex.patch \
26eb8dc403SDave Cobbley    file://0015-xserver-common-disable-TCP-connections.patch \
27eb8dc403SDave Cobbley    file://0001-Don-t-install-Xsession-or-Xserver.patch \
28eb8dc403SDave Cobbley"
29eb8dc403SDave Cobbley
30*213cb269SPatrick Williamsdo_install:append() {
31eb8dc403SDave Cobbley    sed -i 's:^BINDIR=.*$:BINDIR=${bindir}:' ${D}/etc/X11/xserver-common
32eb8dc403SDave Cobbley    # Rename all Xsession files not ending with .sh
33eb8dc403SDave Cobbley    # Unfortunatelly when xinput-calibrator was moved to oe-core
34eb8dc403SDave Cobbley    # its Xsession file got name 30xinput_calibrate.sh and ls -X sorts it
35eb8dc403SDave Cobbley    # last, not respecting numbers for sorting them
36eb8dc403SDave Cobbley    for i in ${D}/${sysconfdir}/X11/Xsession.d/*; do
37eb8dc403SDave Cobbley        echo $i | grep '.sh$' || mv $i $i.sh
38eb8dc403SDave Cobbley    done
39eb8dc403SDave Cobbley}
40eb8dc403SDave Cobbley
41*213cb269SPatrick WilliamsRDEPENDS:${PN} = "xmodmap xrandr xdpyinfo fbset xinput-calibrator"
42eb8dc403SDave Cobbley
43*213cb269SPatrick WilliamsRCONFLICTS:${PN} = "xserver-kdrive-common x11-common"
44*213cb269SPatrick WilliamsRREPLACES:${PN} = "xserver-kdrive-common x11-common"
45eb8dc403SDave Cobbley
46