1SUMMARY = "Remove idle cursor image from screen."
2DESCRIPTION = "This is a rewrite of the popular tool unclutter, but using the x11-xfixes extension."
3
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=b25d2c4cca175f44120d1b8e67cb358d"
6
7SRC_URI = "git://github.com/Airblader/unclutter-xfixes.git;branch=master;protocol=https \
8           file://0001-build-use-autotools.patch"
9SRCREV = "160ae3760a51126eb225ce77d83e4706eccd4ed9"
10
11inherit autotools pkgconfig features_check
12
13REQUIRED_DISTRO_FEATURES = "x11"
14
15DEPENDS = "libev libx11 libxi libxfixes"
16
17S = "${WORKDIR}/git"
18
19do_install:append() {
20    # LICENSE is installed to /usr/share/licenses but we don't want it in the package
21    rm -rf ${D}${datadir}
22}
23