1SUMMARY = "An abstraction layer for touchscreen panel events"
2DESCRIPTION = "Tslib is an abstraction layer for touchscreen panel \
3events, as well as a filter stack for the manipulation of those events. \
4Tslib is generally used on embedded devices to provide a common user \
5space interface to touchscreen functionality."
6HOMEPAGE = "http://tslib.org/"
7
8AUTHOR = "Martin Kepplinger <martink@posteo.de>"
9SECTION = "base"
10LICENSE = "LGPL-2.0-or-later & GPL-2.0-or-later"
11LIC_FILES_CHKSUM = "\
12    file://COPYING;md5=fc178bcd425090939a8b634d1d6a9594 \
13    file://tests/COPYING;md5=a23a74b3f4caf9616230789d94217acb \
14"
15
16SRC_URI = "https://github.com/kergoth/tslib/releases/download/${PV}/tslib-${PV}.tar.xz;downloadfilename=tslib-${PV}.tar.xz \
17           file://ts.conf \
18           file://tslib.sh \
19           "
20SRC_URI[sha256sum] = "aaf0aed410a268d7b51385d07fe4d9d64312038e87c447ec8a24c8db0a15617a"
21
22UPSTREAM_CHECK_URI = "https://github.com/kergoth/tslib/releases"
23
24inherit autotools pkgconfig
25
26PACKAGECONFIG ??= "debounce dejitter evthres iir linear median pthres skip lowpass invert variance input touchkit waveshare"
27PACKAGECONFIG[debounce] = "--enable-debounce,--disable-debounce"
28PACKAGECONFIG[dejitter] = "--enable-dejitter,--disable-dejitter"
29PACKAGECONFIG[evthres] = "--enable-evthres,--disable-evthres"
30PACKAGECONFIG[iir] = "--enable-iir,--disable-iir"
31PACKAGECONFIG[linear] = "--enable-linear,--disable-linear"
32PACKAGECONFIG[median] = "--enable-median,--disable-median"
33PACKAGECONFIG[pthres] = "--enable-pthres,--disable-pthres"
34PACKAGECONFIG[skip] = "--enable-skip,--disable-skip"
35PACKAGECONFIG[lowpass] = "--enable-lowpass,--disable-lowpass"
36PACKAGECONFIG[invert] = "--enable-invert,--disable-invert"
37PACKAGECONFIG[variance] = "--enable-variance,--disable-variance"
38PACKAGECONFIG[input] = "--enable-input,--disable-input"
39PACKAGECONFIG[tatung] = "--enable-tatung,--disable-tatung"
40PACKAGECONFIG[touchkit] = "--enable-touchkit,--disable-touchkit"
41PACKAGECONFIG[waveshare] = "--enable-waveshare,--disable-waveshare"
42PACKAGECONFIG[ucb1x00] = "--enable-ucb1x00,--disable-ucb1x00"
43PACKAGECONFIG[mk712] = "--enable-mk712,--disable-mk712"
44PACKAGECONFIG[h3600] = "--enable-h3600,--disable-h3600"
45PACKAGECONFIG[dmc] = "--enable-dmc,--disable-dmc"
46PACKAGECONFIG[linear-h2200] = "--enable-linear-h2200,--disable-linear-h2200"
47PACKAGECONFIG[corgi] = "--enable-corgi,--disable-corgi"
48PACKAGECONFIG[collie] = "--enable-collie,--disable-collie"
49PACKAGECONFIG[arctic2] = "--enable-arctic2,--disable-arctic2"
50PACKAGECONFIG[dmc_dus3000] = "--enable-dmc_dus3000,--disable-dmc_dus3000"
51PACKAGECONFIG[cy8mrln-palmpre] = "--enable-cy8mrln-palmpre,--disable-cy8mrln-palmpre"
52PACKAGECONFIG[galax] = "--enable-galax,--disable-galax"
53PACKAGECONFIG[one-wire-ts-input] = "--enable-one-wire-ts-input,--disable-one-wire-ts-input"
54PACKAGECONFIG[debug] = "--enable-debug,--disable-debug"
55
56do_install:prepend() {
57    install -m 0644 ${WORKDIR}/ts.conf ${S}/etc/ts.conf
58}
59
60do_install:append() {
61    install -d ${D}${sysconfdir}/profile.d/
62    install -m 0755 ${WORKDIR}/tslib.sh ${D}${sysconfdir}/profile.d/
63}
64
65RPROVIDES:tslib-conf = "libts-0.0-conf"
66
67PACKAGES =+ "tslib-conf tslib-tests tslib-calibrate tslib-uinput"
68DEBIAN_NOAUTONAME:tslib-conf = "1"
69DEBIAN_NOAUTONAME:tslib-tests = "1"
70DEBIAN_NOAUTONAME:tslib-calibrate = "1"
71DEBIAN_NOAUTONAME:tslib-uinput = "1"
72
73RDEPENDS:${PN} = "tslib-conf"
74RRECOMMENDS:${PN} = "pointercal"
75
76FILES:${PN}-dev += "${libdir}/ts/*.la"
77FILES:tslib-conf = "${sysconfdir}/ts.conf ${sysconfdir}/profile.d/tslib.sh ${datadir}/tslib"
78FILES:${PN} = "${libdir}/*.so.* ${libdir}/ts/*.so*"
79FILES:tslib-calibrate += "${bindir}/ts_calibrate"
80FILES:tslib-uinput += "${bindir}/ts_uinput"
81
82FILES:tslib-tests = "${bindir}/ts_harvest ${bindir}/ts_print ${bindir}/ts_print_raw ${bindir}/ts_print_mt \
83                     ${bindir}/ts_test ${bindir}/ts_test_mt ${bindir}/ts_verify ${bindir}/ts_finddev ${bindir}/ts_conf"
84
85BBCLASSEXTEND = "native nativesdk"
86