1SUMMARY  = "SPIRV-Cross is a tool designed for parsing and converting SPIR-V \
2to other shader languages"
3LICENSE  = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
5SECTION = "graphics"
6
7S = "${WORKDIR}/git"
8SRCREV = "ed16b3e69985feaf565efbecea70a1cc2fca2a58"
9SRC_URI = "git://github.com/KhronosGroup/SPIRV-Cross.git;branch=master;protocol=https \
10	file://0001-Add-install-PHONY-target-in-Makefile.patch \
11"
12
13EXTRA_OEMAKE += 'TARGET_DIR_LIB="${D}${libdir}"'
14EXTRA_OEMAKE += 'TARGET_DIR_BIN="${D}${bindir}"'
15
16do_compile () {
17	cd ${S} && oe_runmake
18}
19
20do_install () {
21	cd ${S} && oe_runmake install
22}
23